Stamp Me Loyalty App Support Center

Contact Us

Minimum phone software requirements for using Stamp Me Loyalty?

To use Stamp Me Loyalty on your phone, please see below.


iOS devices:

We do not support iPhone 4 or operating system lower than iOS 8.


Android devices:

We do not support Android phones without bluetooth 4.0, or any operating system lower than version 4.3.


Please see below list of Android phones that work with Stamp Me

Android phones compatible with Stamp Me (as of June 2019) - stampme_supported_android_devices_june_2019.pdf